summaryrefslogtreecommitdiff
path: root/hw/xfree86/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <Alan.Coopersmith@sun.com>2005-08-18 17:14:11 +0000
committerAlan Coopersmith <Alan.Coopersmith@sun.com>2005-08-18 17:14:11 +0000
commita0366ddb8cb1c57b85a5806eb348abc19c7f92d6 (patch)
treecee1b5d1877cc3d3268177d3886aca38d3d3730a /hw/xfree86/Makefile.am
parentea5c49cb17ac956d6dea6bf563e392e61c39da2b (diff)
Replace gnu-makeism with portable rules
Diffstat (limited to 'hw/xfree86/Makefile.am')
-rw-r--r--hw/xfree86/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/hw/xfree86/Makefile.am b/hw/xfree86/Makefile.am
index f379b8e23..6924a6423 100644
--- a/hw/xfree86/Makefile.am
+++ b/hw/xfree86/Makefile.am
@@ -61,9 +61,17 @@ XORG_LIBS = \
# it to install callbacks for those actions.
#
-xkb%.c:
+xkbVT.c:
echo "#define XF86DDXACTIONS" > $@
- echo "#include \"$(top_srcdir)/xkb/ddx$*.c\"" >> $@
+ echo "#include \"$(top_srcdir)/xkb/ddxVT.c\"" >> $@
+
+xkbKillSrv.c:
+ echo "#define XF86DDXACTIONS" > $@
+ echo "#include \"$(top_srcdir)/xkb/ddxKillSrv.c\"" >> $@
+
+xkbPrivate.c:
+ echo "#define XF86DDXACTIONS" > $@
+ echo "#include \"$(top_srcdir)/xkb/ddxPrivate.c\"" >> $@
Xorg_LDADD = $(XORG_LIBS) \
@XSERVER_LIBS@ \