summaryrefslogtreecommitdiff
path: root/hw/Makefile.am
diff options
context:
space:
mode:
authorBen Byer <bbyer@bbyer.local>2007-09-06 05:34:14 -0700
committerBen Byer <bbyer@bbyer.local>2007-09-06 05:34:14 -0700
commit35ec8b89f4cdf5ec48b292d47b2dad42d2fb9534 (patch)
treef44783073734383dbd477818d758c65255cc2ad7 /hw/Makefile.am
parentf3f614cd01ae56d84d61b4f5c907c6edd7c8c6d3 (diff)
DDX changes for XDarwin
Creating a real DDX section for XDarwin instead of stuffing it into the XORG section in a half-assed manner.
Diffstat (limited to 'hw/Makefile.am')
-rw-r--r--hw/Makefile.am12
1 files changed, 4 insertions, 8 deletions
diff --git a/hw/Makefile.am b/hw/Makefile.am
index 99df8e230..30662ccdd 100644
--- a/hw/Makefile.am
+++ b/hw/Makefile.am
@@ -1,5 +1,5 @@
if DMX
-if BUILD_DARWIN
+if XDARWIN
# Darwin does not need the dmx subdir
else
DMX_SUBDIRS = dmx
@@ -7,12 +7,8 @@ endif
endif
if XORG
-if BUILD_DARWIN
-# Darwin does not need the xfree86 subdir
-else
XORG_SUBDIRS = xfree86
endif
-endif
if XVFB
XVFB_SUBDIRS = vfb
@@ -38,15 +34,15 @@ if XPRINT
XPRINT_SUBDIRS = xprint
endif
-if BUILD_DARWIN
-DARWIN_SUBDIRS = darwin
+if XDARWIN
+XDARWIN_SUBDIRS = darwin
endif
SUBDIRS = \
$(XORG_SUBDIRS) \
$(XGL_SUBDIRS) \
$(XWIN_SUBDIRS) \
- $(DARWIN_SUBDIRS) \
+ $(XDARWIN_SUBDIRS) \
$(XVFB_SUBDIRS) \
$(XNEST_SUBDIRS) \
$(DMX_SUBDIRS) \