summaryrefslogtreecommitdiff
path: root/dix/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-09-15 19:17:48 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-09-24 16:36:25 -0700
commite23bffc41b007f1bc2b8f5cd4ac54213062c95cc (patch)
tree0052b22d4dc9701e5550f87b7f75861e156ae29b /dix/Makefile.am
parent9fa73be9fa543a686ea35c861084f5af37d44caa (diff)
Fix build of unit tests when dtrace probes are enabled
ar loses the dtrace probe magic when building static libraries, so we have to link with the .O files in order to resolve the dtrace probe symbols. Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'dix/Makefile.am')
-rw-r--r--dix/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/dix/Makefile.am b/dix/Makefile.am
index 13e5dedd7..764860ce3 100644
--- a/dix/Makefile.am
+++ b/dix/Makefile.am
@@ -56,12 +56,12 @@ Xserver-dtrace.h: $(srcdir)/Xserver.d
# Generate dtrace object code for probes in libdix
dtrace-dix.o: $(top_srcdir)/dix/Xserver.d $(am_libdix_la_OBJECTS)
- $(DTRACE) -G -C -o $@ -s $(top_srcdir)/dix/Xserver.d .libs/*.o
+ $(DTRACE) -G -C -o $@ -s $(top_srcdir)/dix/Xserver.d $(am_libdix_la_OBJECTS:%.lo=.libs/%.o)
noinst_PROGRAMS = dix.O
dix.O: dtrace-dix.o $(am_libdix_la_OBJECTS)
- ld -r -o $@ .libs/*.o
+ ld -r -o $@ $(am_libdix_la_OBJECTS:%.lo=.libs/%.o)
endif
dix.c: