summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2009-10-21 16:46:55 +0900
committerPeter Hutterer <peter.hutterer@who-t.net>2009-10-22 07:53:35 +1000
commite644e322c78d83e445daa64dc3f2f596b2b64016 (patch)
tree8fa7cb4b3205fa9e1b52d83afac4184abef18096 /configure.ac
parent55d3a77eb99c67ed05140f03e3fc4bf24011df35 (diff)
Fix 'distcheck' to use host xkb files but install to build dir
'make distcheck' needs to read xkb files and write out compiled versions as a part of the 'make check' phase. This patch passes suitable options to the configure stage of the distcheck process to read xkb files from the system location and write them to the distcheck _inst directory. Signed-off-by: Keith Packard <keithp@keithp.com> (cherry picked from commit 08e7f62faf72540cb3a6f1023024c145f7fa1a23)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 27701158f..628f410d5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1091,11 +1091,16 @@ AM_CONDITIONAL(INT10MODULE, test "x$INT10MODULE" = xyes)
AC_DEFINE(SHAPE, 1, [Support SHAPE extension])
AC_DEFINE_DIR(XKB_BASE_DIRECTORY, XKBPATH, [Path to XKB data])
-AC_DEFINE_DIR(XKB_BIN_DIRECTORY, bindir, [Path to XKB bin dir])
+AC_ARG_WITH(xkb-bin-directory,
+ AS_HELP_STRING([--with-xkb-bin-directory=DIR], [Directory containing xkbcomp program]),
+ [XKB_BIN_DIRECTORY="$withval"],
+ [XKB_BIN_DIRECTORY="$bindir"])
+
+AC_DEFINE_DIR(XKB_BIN_DIRECTORY, XKB_BIN_DIRECTORY, [Path to XKB bin dir])
dnl Make sure XKM_OUTPUT_DIR is an absolute path
XKBOUTPUT_FIRSTCHAR=`echo $XKBOUTPUT | cut -b 1`
-if [[ x$XKBOUTPUT_FIRSTCHAR != x/ ]] ; then
+if [[ x$XKBOUTPUT_FIRSTCHAR != x/ -a x$XKBOUTPUT_FIRSTCHAR != 'x$' ]] ; then
XKBOUTPUT="$XKB_BASE_DIRECTORY/$XKBOUTPUT"
fi