summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2013-02-01 09:06:20 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2013-05-07 09:40:46 +1000
commit623981ddaeb8836f3b0939e527c0e943f9c4e974 (patch)
tree40b6815c1fafaa71aabab0c1361c14f4e206f819 /configure.ac
parentdce40e2266200421647044ec7e856656d2ef952d (diff)
If neither HAL nor udev backends are enabled, warn the user
If both are missing, input device hotplugging will not work out of the box. While we still have a DBus-API or the user may want to set AAD off all the time, the most likely source of this is misconfiguration (i.e. lack of the udev/hal devel packages). Message printed last to make it more obvious to the user. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Reviewed-by: Keith Packard <keithp@keithp.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0b72860f6..89a7a9db9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2223,6 +2223,14 @@ AC_SUBST([prefix])
AC_CONFIG_COMMANDS([sdksyms], [touch hw/xfree86/sdksyms.dep])
+if test "x$CONFIG_HAL" = xno && test "x$CONFIG_UDEV" = xno; then
+ AC_WARN([
+ ***********************************************
+ Neither HAL nor udev backend will be enabled.
+ Input device hotplugging will not be available!
+ ***********************************************])
+fi
+
AC_OUTPUT([
Makefile
glx/Makefile