summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJon TURNEY <jon.turney@dronecode.org.uk>2012-01-03 00:14:32 +0000
committerJon TURNEY <jon.turney@dronecode.org.uk>2012-05-01 17:01:36 +0100
commit0426e6d65b6598edfbcb2fc66ee65fb08256469e (patch)
treee988aeb77c682cd3fd058e30ab3438d3f4f9e46e /configure.ac
parentf3410b97cf9b48a47bee3d15d232f8a88e75f4ef (diff)
configure.ac: Make default configuration for MinGW disable unsupported extensions and DDXs
Same as the default configuration for Cygwin, --disable-xorg and --disable-dmx DDX by default, and force --disable-xv and other unsupported extensions Signed-off-by: Jon TURNEY <jon.turney@dronecode.org.uk> Reviewed-by: Yaakov Selkowitz <yselkowitz@users.sourceforge.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4afac8268..f81349bd6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -698,7 +698,7 @@ AM_CONDITIONAL(INSTALL_LIBXF86CONFIG, [test "x$INSTALL_LIBXF86CONFIG" = xyes])
dnl DDX Detection... Yes, it's ugly to have it here... but we need to
dnl handle this early on so that we don't require unsupported extensions
case $host_os in
- cygwin*)
+ cygwin* | mingw*)
CONFIG_DBUS_API=no
CONFIG_HAL=no
CONFIG_UDEV=no
@@ -1547,6 +1547,7 @@ if test "x$XORG" = xauto; then
XORG="yes"
case $host_os in
cygwin*) XORG="no" ;;
+ mingw*) XORG="no" ;;
darwin*) XORG="no" ;;
esac
fi
@@ -1948,6 +1949,7 @@ if test "x$DMX" = xauto; then
DMX="$have_dmx"
case $host_os in
cygwin*) DMX="no" ;;
+ mingw*) DMX="no" ;;
darwin*) DMX="no" ;;
esac
fi