summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAdam Jackson <ajax@nwnk.net>2005-07-13 22:59:39 +0000
committerAdam Jackson <ajax@nwnk.net>2005-07-13 22:59:39 +0000
commitf4626bb72b9955846abee018ae31c1aeb51b8dbf (patch)
tree61248946dea4b39670ffc99878daf33865f83617 /configure.ac
parent4f38526566dbcc296d124bb852adfa30ac4d927e (diff)
dlloader is the default in 6.9, but the loader doesn't get told to prefer
dlloader modules unless you -DDLOPEN_HACK.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a71ff0908..141fe4d43 100644
--- a/configure.ac
+++ b/configure.ac
@@ -653,6 +653,9 @@ AC_DEFINE(NEED_XF86_TYPES,1,[Need XFree86 typedefs])
AC_DEFINE(NEED_XF86_PROTOTYPES,1,[Need XFree86 helper functions])
AC_DEFINE(__XSERVERNAME__,"Xorg",[Name of X server])
AC_DEFINE(__XKBDEFRULES__,"xorg",[Default XKB rules])
+# XXX HACK! if anyone cares about elfloader in 7.0 you need to
+# XXX do something smarter here.
+AC_DEFINE(DLOPEN_HACK,1,[Prefer dlloader modules to elfloader])
AC_DEFINE(DLOPEN_SUPPORT,1,[Use libdl-based loader])
AC_DEFINE(DRIVERS,{},[Built-in output drivers])
AC_DEFINE(IDRIVERS,{},[Built-in input drivers])