summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@redhat.com>2005-10-05 21:38:40 +0000
committerKristian Høgsberg <krh@redhat.com>2005-10-05 21:38:40 +0000
commitdc6ac8e46f80157960a24a1be1fb83f22dff45a0 (patch)
treeec677a383f487d84c02a6aa0f8e73d7bf17563e8 /configure.ac
parent8391eaa4aa1ae3744ad8c45f5d148ba362d2c9dd (diff)
Add DGA configure option and add various files that we should be dist'ing.
Simplify xf86DefModeSet.c rule a bit.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 844b245fe..d4e708100 100644
--- a/configure.ac
+++ b/configure.ac
@@ -335,6 +335,7 @@ AC_ARG_ENABLE(xres, [ --disable-xres ], [RES=$enableval], [RES=yes])
AC_ARG_ENABLE(xtrap, [ --enable-xtrap ], [XTRAP=$enableval], [XTRAP=no])
AC_ARG_ENABLE(record, [ --disable-record ], [RECORD=$enableval], [RECORD=yes])
AC_ARG_ENABLE(xv, [ --disable-xv ], [XV=$enableval], [XV=yes])
+AC_ARG_ENABLE(dga, [ --enable-dga ], [DGA=$enableval], [DGA=no])
AC_ARG_ENABLE(screensaver, [ --disable-screensaver ], [SCREENSAVER=$enableval], [SCREENSAVER=yes])
AC_ARG_ENABLE(xdmcp, [ --disable-xdmcp ], [XDMCP=$enableval], [XDMCP=auto])
AC_ARG_ENABLE(xdm-auth-1, [ --disable-xdm-auth-1 ], [XDMAUTH=$enableval], [XDMAUTH=auto])
@@ -417,7 +418,7 @@ XEXT_INC='-I$(top_srcdir)/Xext'
XEXT_LIB='$(top_builddir)/Xext/libXext.la'
dnl Core modules for most extensions, et al.
-REQUIRED_MODULES="randrproto renderproto fixesproto damageproto xcmiscproto xextproto xfont xproto xtrans xau xf86dgaproto xf86miscproto xf86vidmodeproto xf86bigfontproto scrnsaverproto bigreqsproto resourceproto fontenc fontsproto"
+REQUIRED_MODULES="randrproto renderproto fixesproto damageproto xcmiscproto xextproto xfont xproto xtrans xau xf86miscproto xf86vidmodeproto xf86bigfontproto scrnsaverproto bigreqsproto resourceproto fontenc fontsproto"
AM_CONDITIONAL(XV, [test "x$XV" = xyes])
if test "x$XV" = xyes; then
@@ -425,6 +426,12 @@ if test "x$XV" = xyes; then
REQUIRED_MODULES="$REQUIRED_MODULES videoproto"
fi
+AM_CONDITIONAL(DGA, [test "x$DGA" = xyes])
+if test "x$DGA" = xyes; then
+ AC_DEFINE(DGA, 1, [Support DGA extension])
+ REQUIRED_MODULES="$REQUIRED_MODULES xf86dgaproto"
+fi
+
AM_CONDITIONAL(COMPOSITE, [test "x$COMPOSITE" = xyes])
if test "x$COMPOSITE" = xyes; then
AC_DEFINE(COMPOSITE, 1, [Support Composite Extension])