summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <Alan.Coopersmith@sun.com>2005-10-05 02:18:10 +0000
committerAlan Coopersmith <Alan.Coopersmith@sun.com>2005-10-05 02:18:10 +0000
commitda989e988cc96c0ec4f07fceb4c36b30c2e37f4a (patch)
tree2b9fb9d69c12f539a1ae09c366043c36075ff785 /configure.ac
parent9e8b5f3d478ca18a9ff9c26745de77c91a5d36d9 (diff)
Xnest depends on xdmcp & xau modules too
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d970e008e..009dfe99b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -577,6 +577,7 @@ AM_CONDITIONAL(XDMCP, [test "x$XDMCP" = xyes])
if test "x$XDMCP" = xyes; then
AC_DEFINE(XDMCP, 1, [Support XDM Control Protocol])
REQUIRED_MODULES="$REQUIRED_MODULES xdmcp"
+ XNEST_MODULES="$XNEST_MODULES xdmcp"
fi
AM_CONDITIONAL(XDMAUTH, [test "x$XDMAUTH" = xyes])
@@ -584,6 +585,7 @@ if test "x$XDMAUTH" = xyes; then
AC_DEFINE(HASXDMAUTH,1,[Support XDM-AUTH*-1])
if ! test "x$XDMCP" = xyes; then
REQUIRED_MODULES="$REQUIRED_MODULES xdmcp"
+ XNEST_MODULES="$XNEST_MODULES xdmcp"
fi
fi
@@ -702,7 +704,7 @@ fi
dnl Xnest DDX
AC_MSG_CHECKING([whether to build Xnest DDX])
-PKG_CHECK_MODULES(XNESTMODULES, [xfont xext x11], [have_xnest=yes], [have_xnest=no])
+PKG_CHECK_MODULES(XNESTMODULES, [xfont xext x11 xau $XNEST_MODULES], [have_xnest=yes], [have_xnest=no])
if test "x$XNEST" = xauto; then
XNEST="$have_xnest"
fi