summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <anholt@freebsd.org>2005-09-15 06:46:05 +0000
committerEric Anholt <anholt@freebsd.org>2005-09-15 06:46:05 +0000
commitbe2bdab4339e493bb0ac3d0e36508b7aa1cd6e92 (patch)
treed47d9e3ee5107f14d7b94438ea02f73f7bf46f64 /configure.ac
parentef7eef0f68af6bfbb4ee56115ac2f3c1b7425755 (diff)
Bug #3990: Require glproto in the cases that it's necessary (DRI or DMX
with GLX). (spyderous)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5f72f6e40..7fcd148b5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -436,6 +436,9 @@ if test "x$DRI" = xyes; then
AC_DEFINE(XF86DRI, 1, [Build DRI extension])
PKG_CHECK_MODULES([DRIPROTO], [xf86driproto])
PKG_CHECK_MODULES([LIBDRM], [libdrm])
+ if test "x$GLX" = xyes; then
+ PKG_CHECK_MODULES([GL], [glproto])
+ fi
AC_SUBST(DRIPROTO_CFLAGS)
AC_SUBST(LIBDRM_CFLAGS)
fi
@@ -627,6 +630,9 @@ dnl USB sources in DMX require <linux/input.h>
dnl Linux sources in DMX require <linux/keyboard.h>
AC_CHECK_HEADER([linux/keyboard.h], DMX_BUILD_LNX="yes",
DMX_BUILD_LNX="no")
+ if test "x$GLX" = xyes; then
+ PKG_CHECK_MODULES([GL], [glproto])
+ fi
fi
AM_CONDITIONAL([DMX_BUILD_LNX], [test "x$DMX_BUILD_LNX" = xyes])
AM_CONDITIONAL([DMX_BUILD_USB], [test "x$DMX_BUILD_USB" = xyes])