summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <Alan.Coopersmith@sun.com>2005-09-20 15:50:31 +0000
committerAlan Coopersmith <Alan.Coopersmith@sun.com>2005-09-20 15:50:31 +0000
commit7d0f47c43c5c177cae0f375ceaeef892e4c9663a (patch)
tree6baa52360d20dfd81a6341910a7131b2e88f0c47 /configure.ac
parentb623c60745ca486667657fa39ad517d1f7a72794 (diff)
Add --disable-install-setuid option so you can build as non-root and
chown/chmod later. Also disable by default on platforms that don't need setuid root X servers (Darwin & SPARC's, according to InstallXserverSetUID settings in the old Imake config files).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9820f95b2..c2cbbdf66 100644
--- a/configure.ac
+++ b/configure.ac
@@ -338,6 +338,24 @@ AC_ARG_ENABLE(xnest, AS_HELP_STRING([--enable-xnest], [Build Xnest serv
AC_ARG_ENABLE(xwin, AS_HELP_STRING([--enable-xwin], [Build XWin server (default: auto)]), [XWIN=$enableval], [XWIN=auto])
AC_ARG_ENABLE(xprint, AS_HELP_STRING([--enable-xprint], [Build Xprint extension and server (default: auto)]), [XPRINT=$enableval], [XPRINT=auto])
+dnl chown/chmod to be setuid root as part of build
+dnl Replaces InstallXserverSetUID in imake
+AC_ARG_ENABLE(install-setuid,
+ AS_HELP_STRING([--enable-install-setuid],
+ [Install Xorg server as owned by root with setuid bit (default: auto)]),
+ [SETUID=$enableval], [SETUID=auto])
+if test "x$SETUID" = "xauto" ; then
+ case $host_os in
+ darwin*) SETUID="no" ;;
+ *)
+ case $host_cpu in
+ sparc) SETUID="no" ;;
+ *) SETUID="yes" ;;
+ esac
+ esac
+fi
+AM_CONDITIONAL(INSTALL_SETUID, [test "x$SETUID" = "xyes"])
+
dnl Issue an error if xtrans.m4 was not found and XTRANS_CONNECTION_FLAGS macro
dnl was not expanded, since libX11 with no transport types is rather useless.
dnl