summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2017-05-03 15:40:07 -0400
committerPeter Hutterer <peter.hutterer@who-t.net>2017-05-04 11:06:05 +1000
commit111a5615a60565f7b68a7fa69dbac3d289d80c9e (patch)
tree56244406dfa129fc7ff15c1bb610c232b430220a /Makefile.am
parent11c133aafe63c776bde502057243d67fe2c630c8 (diff)
Makefile.am: add the meson files to the tarball
While we're shipping both build systems, we'll likely have 'make dist' generated tarballs - those tarballs should be buildable with meson to have more exposure. List them all explicitly since the list isn't likely to change much. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Reviewed-by: Eric Engestrom <eric@engestrom.ch> Reviewed-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am66
1 files changed, 66 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f0fa2d839..d281ed338 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -128,3 +128,69 @@ install-headers: Makefile
(cd `dirname "$$m"` && make install-sdkHEADERS) \
fi \
done
+
+EXTRA_DIST += \
+ meson_options.txt \
+ include/xorg-config.h.meson.in \
+ hw/xfree86/loader/symbol-test.c \
+ hw/xfree86/common/xf86Build.sh \
+ composite/meson.build \
+ config/meson.build \
+ damageext/meson.build \
+ dbe/meson.build \
+ dix/meson.build \
+ dri3/meson.build \
+ exa/meson.build \
+ fb/meson.build \
+ glamor/meson.build \
+ glx/meson.build \
+ hw/dmx/config/meson.build \
+ hw/dmx/examples/meson.build \
+ hw/dmx/glxProxy/meson.build \
+ hw/dmx/input/meson.build \
+ hw/dmx/meson.build \
+ hw/kdrive/ephyr/meson.build \
+ hw/kdrive/meson.build \
+ hw/kdrive/src/meson.build \
+ hw/meson.build \
+ hw/vfb/meson.build \
+ hw/xfree86/common/meson.build \
+ hw/xfree86/ddc/meson.build \
+ hw/xfree86/dixmods/meson.build \
+ hw/xfree86/dri2/meson.build \
+ hw/xfree86/dri/meson.build \
+ hw/xfree86/drivers/modesetting/meson.build \
+ hw/xfree86/exa/meson.build \
+ hw/xfree86/fbdevhw/meson.build \
+ hw/xfree86/glamor_egl/meson.build \
+ hw/xfree86/i2c/meson.build \
+ hw/xfree86/int10/meson.build \
+ hw/xfree86/loader/meson.build \
+ hw/xfree86/meson.build \
+ hw/xfree86/modes/meson.build \
+ hw/xfree86/os-support/meson.build \
+ hw/xfree86/parser/meson.build \
+ hw/xfree86/ramdac/meson.build \
+ hw/xfree86/shadowfb/meson.build \
+ hw/xfree86/vbe/meson.build \
+ hw/xfree86/vgahw/meson.build \
+ hw/xfree86/x86emu/meson.build \
+ hw/xnest/meson.build \
+ hw/xquartz/meson.build \
+ hw/xwayland/meson.build \
+ include/meson.build \
+ meson.build \
+ miext/damage/meson.build \
+ miext/shadow/meson.build \
+ miext/sync/meson.build \
+ mi/meson.build \
+ os/meson.build \
+ present/meson.build \
+ pseudoramiX/meson.build \
+ randr/meson.build \
+ record/meson.build \
+ render/meson.build \
+ Xext/meson.build \
+ xfixes/meson.build \
+ Xi/meson.build \
+ xkb/meson.build