summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stone <daniel@fooishbar.org>2005-07-01 20:29:53 +0000
committerDaniel Stone <daniel@fooishbar.org>2005-07-01 20:29:53 +0000
commitded56b1a74e6b3e4c48054b7e142d924b19e6104 (patch)
treec2c9fb687494f559cb19e317290e272849c391ae /Makefile.am
parentaabb868920658c9d3979dc194c6bd9702171f101 (diff)
Adding initial build system.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 000000000..0417bf4ee
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,37 @@
+AUTOMAKE_OPTIONS=dist-bzip2 foreign
+
+if COMPOSITE
+COMPOSITE_DIR=composite
+endif
+if XTRAP
+XTRAP_DIR=XTrap
+endif
+
+SUBDIRS= \
+ include \
+ dix \
+ fb \
+ mi \
+ Xext \
+ miext \
+ os \
+ randr \
+ render \
+ Xi \
+ mfb \
+ xkb \
+ afb \
+ cfb \
+ cfb16 \
+ cfb24 \
+ cfb32 \
+ record \
+ xfixes \
+ damageext \
+ $(XTRAP_DIR) \
+ $(COMPOSITE_DIR) \
+ hw
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = xorg-server.pc
+EXTRA_DIST = xorg-server.pc.in