summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stone <daniel@fooishbar.org>2006-01-10 02:32:20 +0000
committerDaniel Stone <daniel@fooishbar.org>2006-01-10 02:32:20 +0000
commit4fc9eb592a446ad5711bdaa82c60e9fe010fd76a (patch)
tree56181f73979e3c8a523970efde210a8e0da9ecaa /configure.ac
parent890ec849479db2510a9b4bc5e5e2f7978ca37b83 (diff)
Bomb out if symlink-mesa.sh failed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 09abc1e32..f1841451c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -538,6 +538,9 @@ if test "x$GLX" = xyes && ! test "x$MESA_SOURCE" = x; then
GLX_LIBS='$(top_builddir)/GL/glx/libglx.la $(top_builddir)/GL/mesa/libGLcore.la'
test -d GL || mkdir GL
$srcdir/GL/symlink-mesa.sh $MESA_SOURCE GL/
+ if test $? -ne 0; then
+ AC_MSG_ERROR([Failed to link Mesa source tree. Please specify a proper path to Mesa sources, or disable GLX.])
+ fi
else
GLX=no
fi