summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-10-03 01:53:56 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-10-03 01:53:56 -0700
commit5aa62bb376608cd0350e46263dec74f861019431 (patch)
tree4d3d095c7f61fbfb794dc6ded8dafa40596a8f52 /configure.ac
parent4d189188c913e6956344689802a582589db04abe (diff)
Migrate to xorg macros 1.3 & XORG_DEFAULT_OPTIONS
Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 5 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 084b3ce..ffe318f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,24 +29,21 @@ AM_MAINTAINER_MODE
AM_CONFIG_HEADER(config.h)
-# Require xorg-macros: XORG_CWARNFLAGS, XORG_CHANGELOG, XORG_WITH_LINT
-m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.2)
+# Require xorg-macros: XORG_DEFAULT_OPTIONS, XORG_WITH_LINT
+m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.3 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.3)
# Check for progs
AC_PROG_CC
AC_PROG_LIBTOOL
-XORG_CWARNFLAGS
+XORG_DEFAULT_OPTIONS
# Check for dependencies
PKG_CHECK_MODULES(XV, x11 xext xextproto videoproto)
AC_SUBST(XV_CFLAGS)
AC_SUBST(XV_LIBS)
-
+
XORG_CHECK_MALLOC_ZERO
-XORG_MANPAGE_SECTIONS
-XORG_RELEASE_VERSION
-XORG_CHANGELOG
dnl Allow checking code with lint, sparse, etc.
XORG_WITH_LINT