summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 1d1b515..7642d24 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,7 +24,13 @@ SUBDIRS = src man
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = xinerama.pc
-EXTRA_DIST = xinerama.pc.in autogen.sh
+EXTRA_DIST = xinerama.pc.in autogen.sh ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog
if LINT
lint: