summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..646c9de
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,26 @@
+dnl $XdotOrg: $
+dnl
+dnl Process this file with autoconf to create configure.
+
+AC_PREREQ([2.57])
+
+AC_INIT(libXi, 1.0, [xorg@lists.freedestkop.org], libXi)
+AM_INIT_AUTOMAKE([dist-bzip2])
+AM_MAINTAINER_MODE
+
+AM_CONFIG_HEADER(src/config.h)
+
+# Check for progs
+AC_PROG_CC
+AC_PROG_LIBTOOL
+
+# Checks for pkg-config packages
+PKG_CHECK_MODULES(XI, xproto x11 xextproto xext inputproto)
+AC_SUBST(XI_CFLAGS)
+AC_SUBST(XI_LIBS)
+
+AC_OUTPUT([Makefile
+ src/Makefile
+ man/Makefile
+ xi.pc])
+