summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter@cs.unisa.edu.au>2008-05-29 12:45:57 +0930
committerPeter Hutterer <peter@cs.unisa.edu.au>2008-05-29 12:46:24 +0930
commit9831db88ee8e69dc6cf8fad0ac83d40bedd5c463 (patch)
tree64eb02e88b0583a3c7e509a65c8b6f13df246586 /configure.ac
parentfd8198513c865f616be8059907550db7f777b089 (diff)
Don't fail man build when missing xmlto.
If xmlto is missing during configure, print out a warning and just do an empty man build with no man pages at all. Better than failing with obscure errors.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c5703ce..92ff3c8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,6 +24,9 @@ AC_SUBST(XI_LIBS)
AC_ARG_VAR([XMLTO], [Path to xmlto command])
AC_PATH_PROG([XMLTO], [xmlto])
AM_CONDITIONAL([HAVE_XMLTO], [test "x$XMLTO" != "x"])
+if test "x$XMLTO" = "x"; then
+ AC_MSG_WARN([xmlto not found - cannot create man pages without it])
+fi
XORG_CHECK_MALLOC_ZERO
XORG_MANPAGE_SECTIONS