summaryrefslogtreecommitdiff
path: root/src/fontfile/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/fontfile/Makefile.am')
-rw-r--r--src/fontfile/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/fontfile/Makefile.am b/src/fontfile/Makefile.am
new file mode 100644
index 0000000..1ba16b9
--- /dev/null
+++ b/src/fontfile/Makefile.am
@@ -0,0 +1,32 @@
+FONTDIR=${libdir}/X11/fonts
+FONTENCDEFS = -DFONT_ENCODINGS_DIRECTORY=\"$(FONTDIR)/encodings/encodings.dir\"
+
+INCLUDES = \
+ -I${top_srcdir}/include/X11/fonts \
+ $(FONTENCDEFS)
+
+noinst_LTLIBRARIES = libfontfile.la
+
+libfontfile_la_LIBADD = \
+ $(Z_LIBS)
+
+libfontfile_la_SOURCES = \
+ bitsource.c \
+ bufio.c \
+ decompress.c \
+ defaults.c \
+ dirfile.c \
+ encparse.c \
+ ffcheck.c \
+ fileio.c \
+ filewr.c \
+ fontdir.c \
+ fontenc.c \
+ fontencI.h \
+ fontencc.c \
+ fontfile.c \
+ fontscale.c \
+ gunzip.c \
+ printerfont.c \
+ register.c \
+ renderers.c