summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJulien Cristau <jcristau@debian.org>2008-11-04 19:24:29 +0100
committerJulien Cristau <jcristau@debian.org>2008-11-04 19:26:45 +0100
commitf859a76b0f325b07952ad1c5c818318307c589b0 (patch)
tree2cb836fef7fd18d65ef8177cc2ca694d893f890c /configure.ac
parent6bf52de1fb84d61b227daf7a7077af9ea3ec27a3 (diff)
Don't clobber CFLAGS in configure
This lets the user set CFLAGS when running make.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index aa689a4..eaa1821 100644
--- a/configure.ac
+++ b/configure.ac
@@ -209,11 +209,11 @@ PKG_CHECK_MODULES(XFONT, xproto xtrans fontsproto fontenc)
XTRANS_CONNECTION_FLAGS
if test "x$GCC" = "xyes"; then
- GCC_WARNINGS="-Wall -Wpointer-arith -Wstrict-prototypes \
+ CWARNFLAGS="-Wall -Wpointer-arith -Wstrict-prototypes \
-Wmissing-prototypes -Wmissing-declarations \
-Wnested-externs -fno-strict-aliasing"
- CFLAGS="$GCC_WARNINGS $CFLAGS"
fi
+AC_SUBST([CWARNFLAGS])
case $host_os in
linux*)
@@ -226,9 +226,7 @@ case $host_os in
OS_CFLAGS=
;;
esac
-
-CFLAGS="$CFLAGS $XFONT_CFLAGS $OS_CFLAGS"
-LIBS="$LIBS $XFONT_LIBS"
+AC_SUBST([OS_CFLAGS])
XORG_RELEASE_VERSION