summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2014-05-15 22:44:38 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2014-05-23 17:21:00 -0700
commitc2b7758d268fd98e09c3e66a0e7717b47ff12a47 (patch)
treefe221051127d32bc2832638143121d3629317b0e /configure.ac
parenta81f1a9bd3cd0a9d45d93d5b9e392b4e08ac60f7 (diff)
Don't compile bitmap source files for disabled formats
pcfread.c is a special case - it's needed for either reading pcf files from disk (--enable-pcfformat) or from the builtin fonts in memory (--enable-builtins), so needed a new AM_CONDITIONAL case. Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com> Reviewed-by: RĂ©mi Cardona <remi@gentoo.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 30f4d6d..13fe3e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -153,6 +153,9 @@ if test "x$XFONT_PCFFORMAT" = xyes; then
XFONT_BITMAP=yes
fi
+AM_CONDITIONAL(XFONT_PCF_OR_BUILTIN,
+ [test "x$XFONT_PCFFORMAT" = xyes -o "x$XFONT_BUILTINS" = xyes])
+
AC_ARG_ENABLE(bdfformat,
AS_HELP_STRING([--disable-bdfformat],
[Support BDF format bitmap fonts (default: enabled)]),