summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-10-07 10:44:27 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-10-07 11:06:56 -0700
commit18053ffbf92473ffce23a3c5182de92b608b9cdf (patch)
tree31f310a305afc94fba893a6b893d683db3d61f2d /configure.ac
parent96a4daad7097ce94d4340a4e9ce779e378f9b83c (diff)
Convert documentation from troff to DocBook/XML
Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bd096f4..5c0a4a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -49,6 +49,18 @@ PKG_PROG_PKG_CONFIG
XORG_DEFAULT_OPTIONS
+# xmlto is used to convert doc/fontlib.xml from DocBook to PDF/HTML
+AC_ARG_VAR([XMLTO], [Path to xmlto command])
+AC_PATH_PROG([XMLTO], [xmlto])
+AM_CONDITIONAL([HAVE_XMLTO], [test "x$XMLTO" != "x"])
+
+# Option to enable support for building developer internals docs
+AC_ARG_ENABLE(devel-docs,
+ AS_HELP_STRING([--enable-devel-docs],
+ [Build internals documentation for developers (default: enabled)]),
+ [DEVEL_DOCS=$enableval], [DEVEL_DOCS=yes])
+AM_CONDITIONAL([MAKE_DEVEL_DOCS], [test "x$DEVEL_DOCS" = "xyes"])
+
# Look for headers
AC_CHECK_HEADERS([endian.h poll.h sys/poll.h])
AC_CHECK_FUNCS([poll])