summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2019-08-03 13:45:54 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2019-08-03 13:54:35 -0700
commitc4ed2e069dc8aa5b8b7ef2fc926ae8584ff2a67b (patch)
tree0eb30743859df68a6b50d621a46d28fd9d078268 /Makefile.am
parent77ae4048564eff2e96b80cedfac013877e46d506 (diff)
Add some unit testing utilities
The test/utils directory contains some standalone test programs for testing libXfont funtionality without needing a full X server session. They could be used to generate automated unit testing in the future, but that work has not yet been done. [v2: updated original work from libXfont 1.5 to 2.0 API & makefiles] Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7c0546e..a4a8009 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -157,6 +157,17 @@ endif
EXTRA_DIST = src/builtins/buildfont README.md
+# Test utilities
+EXTRA_DIST += test/utils/README
+
+TEST_UTIL_SRCS = test/utils/font-test-utils.c test/utils/font-test-utils.h
+
+noinst_PROGRAMS = lsfontdir
+
+lsfontdir_SOURCES = test/utils/lsfontdir.c $(TEST_UTIL_SRCS)
+lsfontdir_LDADD = libXfont2.la
+
+
MAINTAINERCLEANFILES = ChangeLog INSTALL
.PHONY: ChangeLog INSTALL