summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichel Dänzer <michel.daenzer@amd.com>2016-09-16 15:59:16 +0900
committerMichel Dänzer <michel@daenzer.net>2016-09-16 15:59:16 +0900
commitaa8a3fa2468094cd37959179e8417ba7ba0a326c (patch)
tree81464e9bb823f7039469b6f6be493bb1cd286571 /configure.ac
parentcd3acb75718dfd42dd25d58b4e7bd4db27b659d8 (diff)
Fix handling of configure option --with-xorg-conf-dir
There were two problems: I accidentally changed the variable name in the AC_ARG_WITH stanza from configdir to xorgconfigdir, so specifying --with-xorg-conf-dir wouldn't work correctly. Fix this back to configdir. If neither --with-xorg-conf-dir nor --prefix is specified on the command line, the $prefix variable doesn't contain "/usr/local" (the default prefix) yet at this point but "NONE". So make install would attempt to install 10-amdgpu.conf in ${DESTDIR}NONE/share/X11/xorg.conf.d/ . Fix this by leaving ${prefix} verbatim in the default value, to be resolved by make. Also print the configdir value along with the values of other similar configuration variables. Reported-by: Timo Aaltonen <tjaalton@debian.org> Reviewed-by: Julien Cristau <jcristau@debian.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 9166c3f..68e1feb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -89,9 +89,9 @@ PKG_CHECK_EXISTS([xorg-server >= 1.16],
[sysconfigdir=""])
AC_ARG_WITH(xorg-conf-dir,
AS_HELP_STRING([--with-xorg-conf-dir=DIR],
- [Default xorg.conf.d directory [[default=$prefix/share/X11/xorg.conf.d/]]]),
- [xorgconfdir="$withval"],
- [xorgconfdir="$prefix/share/X11/xorg.conf.d"])
+ [Default xorg.conf.d directory [[default=${prefix}/share/X11/xorg.conf.d]]]),
+ [configdir="$withval"],
+ [configdir='${prefix}/share/X11/xorg.conf.d'])
AC_SUBST(configdir)
AM_CONDITIONAL(HAS_XORG_CONF_DIR, [test "x$sysconfigdir" != "x"])
@@ -279,6 +279,7 @@ echo " prefix: $prefix"
echo " exec_prefix: $exec_prefix"
echo " libdir: $libdir"
echo " includedir: $includedir"
+echo " configdir: $configdir"
echo ""
echo " CFLAGS: $CFLAGS"