summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJammy Zhou <Jammy.Zhou@amd.com>2015-05-30 00:31:44 +0800
committerMichel Dänzer <michel.daenzer@amd.com>2015-05-29 18:47:55 +0900
commit7363156b7c077def2aaf9a4573410817f5e92610 (patch)
treec224cb87d6a09f2ac3de73a5a1a3c0770bf45158 /configure.ac
parente75e9f39c95b8b563885882bf29d776861cd6ca3 (diff)
Check GBM_BO_USE_LINEAR correctly v2
v2: remove the check for gbm.h Signed-off-by: Jammy Zhou <Jammy.Zhou@amd.com> Reviewed-by: Michel Dänzer <michel.daenzer@amd.com> Reviewed-by: Alex Deucher <alexander.deucher@amd.com> [v1]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c2411d9..b26eebb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -158,6 +158,11 @@ if test "x$have_list_h" = xyes; then
#include "list.h"])
fi
+AC_CHECK_DECL(GBM_BO_USE_LINEAR,
+ [AC_DEFINE(HAVE_GBM_BO_USE_LINEAR, 1, [Have GBM_BO_USE_LINEAR])], [],
+ [#include <stdlib.h>
+ #include <gbm.h>])
+
CPPFLAGS="$SAVE_CPPFLAGS"
PKG_CHECK_MODULES([PCIACCESS], [pciaccess >= 0.8.0])