summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichel Dänzer <michel.daenzer@amd.com>2016-09-14 18:33:42 +0900
committerMichel Dänzer <michel@daenzer.net>2016-09-14 18:33:42 +0900
commitcd3acb75718dfd42dd25d58b4e7bd4db27b659d8 (patch)
treec42a600a0f33718653cdbc242571fce3159bff30 /configure.ac
parent0f8df8584ad61a3e47fe303b34cd7b0c4ed08bb0 (diff)
Use --with-xorg-conf-dir=$prefix/share/X11/xorg.conf.d by default
We were using the result of `pkg-config --variable=sysconfigdir xorg-server` before, which may not be inside $prefix, so make install might fail for 10-amdgpu.conf . Fixes make distcheck in that case, and possibly also 10-amdgpu.conf seemingly missing from some distribution packages. This matches what some (though not all) input drivers are doing for their xorg.conf.d snippets.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index dd5905f..9166c3f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -89,9 +89,9 @@ PKG_CHECK_EXISTS([xorg-server >= 1.16],
[sysconfigdir=""])
AC_ARG_WITH(xorg-conf-dir,
AS_HELP_STRING([--with-xorg-conf-dir=DIR],
- [Default xorg.conf.d directory [[default=from $PKG_CONFIG xorg-server]]]),
- [configdir="$withval"],
- [configdir="$sysconfigdir"])
+ [Default xorg.conf.d directory [[default=$prefix/share/X11/xorg.conf.d/]]]),
+ [xorgconfdir="$withval"],
+ [xorgconfdir="$prefix/share/X11/xorg.conf.d"])
AC_SUBST(configdir)
AM_CONDITIONAL(HAS_XORG_CONF_DIR, [test "x$sysconfigdir" != "x"])