summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichel Dänzer <michel.daenzer@amd.com>2015-04-24 09:57:27 +0900
committerMichel Dänzer <michel.daenzer@amd.com>2015-04-24 09:57:27 +0900
commita49ad11af18dad74506c2f69d7bbda07b67529d2 (patch)
tree2fd08c25248ecfbb4969f3aa5284837db7edac49 /configure.ac
parentfa4aed6cf56048a6520eac57514e38db3685cd15 (diff)
Add 10-amdgpu.conf xorg.conf.d snippet
This instructs Xorg >= 1.16 to try loading the amdgpu driver for devices managed by the amdgpu kernel driver. Reviewed-by: Alex Deucher <alexander.deucher@amd.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1766d9c..ead206e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -81,6 +81,19 @@ PKG_CHECK_MODULES(XEXT, [xextproto >= 7.0.99.1],
HAVE_XEXTPROTO_71="no")
AM_CONDITIONAL(HAVE_XEXTPROTO_71, [ test "$HAVE_XEXTPROTO_71" = "yes" ])
+# Define a configure option for an alternate X Server configuration directory
+# Section "OutputClass" is only supported as of xserver 1.16
+PKG_CHECK_EXISTS([xorg-server >= 1.16],
+ [sysconfigdir=`$PKG_CONFIG --variable=sysconfigdir xorg-server`],
+ [sysconfigdir=""])
+AC_ARG_WITH(xorg-conf-dir,
+ AS_HELP_STRING([--with-xorg-conf-dir=DIR],
+ [Default xorg.conf.d directory [[default=from $PKG_CONFIG xorg-server]]]),
+ [configdir="$withval"],
+ [configdir="$sysconfigdir"])
+AC_SUBST(configdir)
+AM_CONDITIONAL(HAS_XORG_CONF_DIR, [test "x$sysconfigdir" != "x"])
+
AC_ARG_ENABLE([udev],
AS_HELP_STRING([--disable-udev], [Disable libudev support [default=auto]]),
[enable_udev="$enableval"],
@@ -212,6 +225,7 @@ AC_CONFIG_FILES([
Makefile
src/Makefile
man/Makefile
+ conf/Makefile
])
AC_OUTPUT