summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichel Dänzer <michel.daenzer@amd.com>2015-11-19 17:05:05 +0900
committerMichel Dänzer <michel@daenzer.net>2015-11-20 12:14:03 +0900
commit43c2dc1aab682d5b6ad49d24983d6382c4f305bb (patch)
tree01c9386fa447dd4f65972c66f0fd03ce4c220508 /configure.ac
parent84cab5738a315e9825bd0864c4f0fc5b03eb81a1 (diff)
glamor: Deal with glamor_egl_destroy_textured_pixmap being removed
When it's not available, it's safe to call down to the glamor DestroyPixmap hook instead. (ported from radeon commit 10b7c3def58bb34acc38f076bc230e25b454ab79) Reviewed-by: Alex Deucher <alexander.deucher@amd.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3955b68..a884882 100644
--- a/configure.ac
+++ b/configure.ac
@@ -133,6 +133,12 @@ if test "x$GLAMOR" != "xno"; then
[Have glamor_glyphs_init API])], [],
[#include "xorg-server.h"
#include "glamor.h"])
+
+ AC_CHECK_DECL(glamor_egl_destroy_textured_pixmap,
+ [AC_DEFINE(HAVE_GLAMOR_EGL_DESTROY_TEXTURED_PIXMAP, 1,
+ [Have glamor_egl_destroy_textured_pixmap API])], [],
+ [#include "xorg-server.h"
+ #include "glamor.h"])
fi
PKG_CHECK_MODULES(LIBGL, [gl])