summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichel Dänzer <michel.daenzer@amd.com>2016-09-16 16:36:23 +0900
committerMichel Dänzer <michel@daenzer.net>2016-09-20 17:19:25 +0900
commit97d7386caf7ba53d2cf398b8a9bb65d0a2a4770a (patch)
tree9254878543e64e8a84d54ce16bf4f336f6a8d665 /configure.ac
parentaa8a3fa2468094cd37959179e8417ba7ba0a326c (diff)
Untangle HAS_XORG_CONF_DIR / --with-xorg-conf-dir lines in configure.ac
$sysconfigdir used to be part of the default --with-xorg-conf-dir value, but it no longer is. Reviewed-by: Alex Deucher <alexander.deucher@amd.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 68e1feb..c3af085 100644
--- a/configure.ac
+++ b/configure.ac
@@ -82,18 +82,19 @@ PKG_CHECK_MODULES(XEXT, [xextproto >= 7.0.99.1],
HAVE_XEXTPROTO_71="no")
AM_CONDITIONAL(HAVE_XEXTPROTO_71, [ test "$HAVE_XEXTPROTO_71" = "yes" ])
-# Define a configure option for an alternate X Server configuration directory
# Section "OutputClass" is only supported as of xserver 1.16
PKG_CHECK_EXISTS([xorg-server >= 1.16],
[sysconfigdir=`$PKG_CONFIG --variable=sysconfigdir xorg-server`],
[sysconfigdir=""])
+AM_CONDITIONAL(HAS_XORG_CONF_DIR, [test "x$sysconfigdir" != "x"])
+
+# Define a configure option for an alternate X Server configuration directory
AC_ARG_WITH(xorg-conf-dir,
AS_HELP_STRING([--with-xorg-conf-dir=DIR],
[Default xorg.conf.d directory [[default=${prefix}/share/X11/xorg.conf.d]]]),
[configdir="$withval"],
[configdir='${prefix}/share/X11/xorg.conf.d'])
AC_SUBST(configdir)
-AM_CONDITIONAL(HAS_XORG_CONF_DIR, [test "x$sysconfigdir" != "x"])
AC_ARG_ENABLE([udev],
AS_HELP_STRING([--disable-udev], [Disable libudev support [default=auto]]),