summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichel Dänzer <michel.daenzer@amd.com>2015-08-07 12:39:24 +0900
committerMichel Dänzer <michel@daenzer.net>2015-08-11 12:33:09 +0900
commit4c425e9c5c038504a0f0498dd800ab1fb40bf0c5 (patch)
tree7e124e7787540454f212758ae973e3a72ab00f9b /configure.ac
parentbb989e173dc364a7d68e50d7e819d0e0ee133d2f (diff)
glamor: Add amdgpu_glamor_finish to wait for glamor rendering to finish
This is a bit sneaky, because it calls glFinish directly from the driver, but it seems to work fine. Reviewed-by: Alex Deucher <alexander.deucher@amd.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 85892fa..e350ef6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -135,6 +135,8 @@ if test "x$GLAMOR" != "xno"; then
#include "glamor.h"])
fi
+ PKG_CHECK_MODULES(LIBGL, [gl])
+
if test "x$GLAMOR_XSERVER" != xyes; then
PKG_CHECK_MODULES(LIBGLAMOR, [glamor >= 0.6.0])
PKG_CHECK_MODULES(LIBGLAMOR_EGL, [glamor-egl])