summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-08-27 14:20:02 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-08-27 14:20:02 -0700
commit56f0b5dfb1486e262eb514fac44c73cea4bb4471 (patch)
tree74c1f57e30dfbcd7788e869e9aad20e1b6d012a6 /Makefile.am
parentc8d205c30547ca526404a0b257c3cc5d40970be6 (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index fbd5ed6..bb177d5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,8 +37,16 @@ appmandir = $(APP_MAN_DIR)
appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
-EXTRA_DIST = $(appman_PRE)
+EXTRA_DIST = $(appman_PRE) ChangeLog autogen.sh
CLEANFILES = $(appman_DATA)
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog
SED = sed