summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-06-28 15:22:52 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-06-28 15:22:52 +0000
commitf9b186fdd589267fc8d448ffc5da6d775afe01f2 (patch)
treec7a73c21b3e75109aba12704c3db4728907dbabe /Makefile.am
parent9bc6e165c4c22f0eb412b306b7e0032a0f6dcac0 (diff)
Add buildsystem for oclock
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am55
1 files changed, 55 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..1103f6f
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,55 @@
+#
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+bin_PROGRAMS = oclock
+
+oclock_CFLAGS = $(DEP_CFLAGS)
+oclock_LDADD = $(DEP_LIBS) -lm
+
+oclock_SOURCES = \
+ Clock.c \
+ Clock.h \
+ ClockP.h \
+ oclock.c \
+ transform.c \
+ transform.h
+
+dist_man_MANS = \
+ oclock.man
+
+# App default files (*.ad)
+
+appdefaultdir = $(sysconfdir)/X11/app-defaults
+
+
+APPDEFAULTFILES = \
+ Clock-col
+
+
+$(APPDEFAULTFILES): %: %.ad
+ cp $< $@
+
+appdefault_DATA = $(APPDEFAULTFILES)
+
+EXTRA_DIST = $(foreach FILE, $(APPDEFAULTFILES), $(FILE).ad) oclock.bit oclmask.bit
+
+CLEANFILES = $(APPDEFAULTFILES)
+