summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg Kristensen <kristian.h.kristensen@intel.com>2015-08-05 11:55:09 -0700
committerKristian Høgsberg Kristensen <kristian.h.kristensen@intel.com>2015-08-05 11:58:59 -0700
commit5f9bc98a55d8077f1b42e953d573c4e655832bfa (patch)
tree296215beaf405985527669447a1a6f70f44fab38 /configure.ac
parent78e2a2f245fa66773f34ea68bdbcc2c62d382a9b (diff)
configure.ac: Fix chmod on intel_aubdump the right way
autoconf executes the init commands after each file it creates, causing these errors at configure time: ... chmod: cannot access 'tools/intel_aubdump': No such file or directory config.status: creating tools/Makefile chmod: cannot access 'tools/intel_aubdump': No such file or directory config.status: creating tools/intel_aubdump config.status: creating tools/quick_dump/Makefile ... Once it creates intel_aubdump, the errors go away. When I first added the chmod command, I already had a tools/intel_aubdump in my tree and didn't get the error. Split the intel_aubdump creation into its own AC_CONFIG_FILES() invocation to avoid this. Signed-off-by: Kristian Høgsberg Kristensen <kristian.h.kristensen@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index a5c38f139..19f6fa4f9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -255,7 +255,6 @@ AC_CONFIG_FILES([
scripts/Makefile
tests/Makefile
tools/Makefile
- tools/intel_aubdump
tools/quick_dump/Makefile
tools/null_state_gen/Makefile
debugger/Makefile
@@ -265,8 +264,9 @@ AC_CONFIG_FILES([
assembler/test/Makefile
assembler/intel-gen4asm.pc
overlay/Makefile
- ],
- [chmod +x $(topbuilddir)/tools/intel_aubdump])
+ ])
+
+AC_CONFIG_FILES([tools/intel_aubdump], [chmod +x tools/intel_aubdump])
AC_OUTPUT