summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorsvu <svu>2005-08-06 15:59:05 +0000
committersvu <svu>2005-08-06 15:59:05 +0000
commit8effeaeeaa272fd7375f6983a668b45695b60339 (patch)
treeb0ae35ff925c9e4f3866e80d2278283af79863d1 /Makefile.am
parentcc10f76ec1feb16a193d751bf2ff52393e0380ef (diff)
fixing xkbcomp symlink
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 9 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index d4ffb92e..b7fbc88d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,14 +12,17 @@ DISTCLEANFILES=intltool-extract intltool-merge intltool-update
dnl ACLOCAL_AMFLAGS = -I m4
-if CREATE_XKBCOMP_SYMLINK
-install-data-hook:
- ln -sf ../../../bin/xkbcomp $(DESTDIR)$(xkb_base)/xkbcomp
+install-compiled:
rm -f $(DESTDIR)$(xkb_base)/compiled
ln -sf /var/lib/xkb $(DESTDIR)$(xkb_base)/compiled
+
+if CREATE_XKBCOMP_SYMLINK
+install-xkbcomp:
+ ln -sf $(XKBCOMP) $(DESTDIR)$(xkb_base)/xkbcomp
+
else
-install-data-hook:
- rm -f $(DESTDIR)$(xkb_base)/compiled
- ln -sf /var/lib/xkb $(DESTDIR)$(xkb_base)/compiled
+install-xkbcomp:
endif
+
+install-data-hook: install-compiled install-xkbcomp