summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPino Toscano <pino@kde.org>2008-04-21 15:16:44 +0000
committerPino Toscano <pino@kde.org>2008-04-21 15:16:44 +0000
commitf7bddf8cb0d11b90e7e0f6f02c0e77135ce6fda9 (patch)
tree314fd897934f2d7d51bb9286dd64e44e520a1a40 /Makefile.am
parent07a7effbe54d2f3e53c30332c1cb206ede75b7ae (diff)
Makefile.am: use $(top_builddir) instead of $(builddir) in the
"check" target, this way it works also with automake 1.9.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 4e68e2d..4e0f151 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -63,11 +63,11 @@ check:
xmllint --noout --valid $(srcdir)/freedesktop.org.xml; \
fi
@if test -d CVS/ && test -x ../xdgmime/src/test-mime-data ; then \
- mkdir -p $(builddir)/temp-mime-dir/mime/packages ; \
- cp -a $(builddir)/freedesktop.org.xml $(builddir)/temp-mime-dir/mime/packages/ ; \
- XDG_DATA_DIRS="$(builddir)/temp-mime-dir/" $(builddir)/update-mime-database "$(builddir)/temp-mime-dir/mime/" ; \
- XDG_DATA_DIRS="$(builddir)/temp-mime-dir/" ../xdgmime/src/test-mime-data -v tests/list || exit 1; \
- rm -rf "$(builddir)/temp-mime-dir/" ; \
+ mkdir -p $(top_builddir)/temp-mime-dir/mime/packages ; \
+ cp -a $(top_builddir)/freedesktop.org.xml $(top_builddir)/temp-mime-dir/mime/packages/ ; \
+ XDG_DATA_DIRS="$(top_builddir)/temp-mime-dir/" $(top_builddir)/update-mime-database "$(top_builddir)/temp-mime-dir/mime/" ; \
+ XDG_DATA_DIRS="$(top_builddir)/temp-mime-dir/" ../xdgmime/src/test-mime-data -v tests/list || exit 1; \
+ rm -rf "$(top_builddir)/temp-mime-dir/" ; \
fi
@if `grep comment $(srcdir)/freedesktop.org.xml.in | grep -v _comment | grep -q -v '<!'` ; then \
echo "***************************************************************************" ; \