summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2008-02-21 15:14:03 +0000
committerBastien Nocera <hadess@hadess.net>2008-02-21 15:14:03 +0000
commitbcc5428d96ac5113c400b5149ea63d8bcf23b8f7 (patch)
tree72796061628873b5b652a35d54d3b9c5075ec69d /Makefile.am
parentd37d60fe64da9a8c76850521111ff5f90f7790ae (diff)
* freedesktop.org.xml.in: Patch from Pino Toscano
<pino@kde.org> to mark more comments as translatable (Closes: #14605) * Makefile.am: Add a check for untranslated comments in the check target
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 744e95c..4b6464d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -69,4 +69,8 @@ check:
XDG_DATA_DIRS="$(builddir)/temp-mime-dir/" ../xdgmime/src/test-mime-data -v tests/list; \
rm -rf "$(builddir)/temp-mime-dir/" ; \
fi
+ if `grep comment $(srcdir)/freedesktop.org.xml.in | grep -v _comment | grep -q -v '<!'` ; then \
+ echo "Some comments are not marked as translatable, fix before committing" ; \
+ exit 1 ; \
+ fi