summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2011-03-30 12:02:32 +0100
committerBastien Nocera <hadess@hadess.net>2011-03-30 16:26:28 +0100
commit725d754d1d602a6629213fcb151bd7c9d1563df6 (patch)
treef72466a97c4888c8d319a7a7087106a4220a5311 /Makefile.am
parent33d8528a21a164c95fc464466a404f33ea33bbcd (diff)
build: Update for the new Transifex way of doing things
en_GB: Progress, my arse. en_US: Progress, my ass. fr_FR: Progrés, mon cul.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c4a5f55..1c3edf3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -100,7 +100,7 @@ check: create-pot freedesktop.org.xml update-mime-database check-translations
fi
@echo Number of mime-types that might need generic-icon: `grep "mime-type type=" $(srcdir)/freedesktop.org.xml.in | grep -v video/ | grep -v image/ | grep -v text/ | grep -v audio/ | grep -v "octet-stream" | wc -l` ; \
echo Number of mime-types with a generic icon: `grep "generic-icon name=" $(srcdir)/freedesktop.org.xml.in | wc -l` ;
-
+
check-translations:
@for i in $(top_srcdir)/po/*.po ; do \
if ! grep -q `basename $$i | sed 's,.po,,'` $(top_srcdir)/po/LINGUAS ; then \
@@ -109,6 +109,10 @@ check-translations:
fi; \
done;
+update-translations: create-pot
+ @tx pull --all --force --skip
+ @tx push --source
+
# Build ChangeLog from GIT history
ChangeLog:
@if test -f $(top_srcdir)/.git/HEAD; then \