summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rw-r--r--src/xcb_util.c5
2 files changed, 6 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 6609c93..43a2e59 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,6 +7,8 @@ libxcb (1.0-1) experimental; urgency=low
check first started shipping the pkg-config file.
* Add Build-Depends on libpthread-stubs0-dev.
* Add XS-Vcs-Git field.
+ * Cherry-pick post-1.0 changes from master:
+ * "NetBSD doesn't have AI_ADDRCONFIG: use it only if it's available."
-- Josh Triplett <josh@freedesktop.org> Fri, 24 Nov 2006 00:51:41 -0800
diff --git a/src/xcb_util.c b/src/xcb_util.c
index bd9f2b5..eeee1dd 100644
--- a/src/xcb_util.c
+++ b/src/xcb_util.c
@@ -176,7 +176,10 @@ static int _xcb_open_decnet(const char *host, const unsigned short port)
static int _xcb_open_tcp(char *host, const unsigned short port)
{
int fd = -1;
- struct addrinfo hints = { AI_ADDRCONFIG
+ struct addrinfo hints = { 0
+#ifdef AI_ADDRCONFIG
+ | AI_ADDRCONFIG
+#endif
#ifdef AI_NUMERICSERV
| AI_NUMERICSERV
#endif