summaryrefslogtreecommitdiff
path: root/XorgModuleABIVersions.mdwn
diff options
context:
space:
mode:
authorAlanCoopersmith <AlanCoopersmith@web>2013-09-17 16:21:59 -0700
committerxorg <iki-xorg@freedesktop.org>2013-09-17 16:21:59 -0700
commitd59b647a336ab422c607ce815a2cafb19933fc73 (patch)
treefd39bfc28199c6f2f95b91d4e5660fe9b360d239 /XorgModuleABIVersions.mdwn
parentc6543a474960e49ab0432b76c25a051773028459 (diff)
Add ABI versions for 1.12-1.14 & a little more explanation
Diffstat (limited to 'XorgModuleABIVersions.mdwn')
-rw-r--r--XorgModuleABIVersions.mdwn16
1 files changed, 9 insertions, 7 deletions
diff --git a/XorgModuleABIVersions.mdwn b/XorgModuleABIVersions.mdwn
index 3a158835..76ddbe58 100644
--- a/XorgModuleABIVersions.mdwn
+++ b/XorgModuleABIVersions.mdwn
@@ -4,16 +4,18 @@ This major number of the ABI version (_**x**_.\*) is incremented when there are
Modules reporting they require a incompatible version number will not be loaded unless the `-ignoreABI` option is used. (Modules can also check ABI versions themselves, and choose which function variant to call or structure variant to access, based on the reported versions - this is the option used by some closed source drivers for instance.)
-ABI numbers may increment multiple times during Xorg server development cycles, to track changes for those following the head of the development stream. X.Org tries to avoid changing ABI's incompatibly in stable release branches.
+ABI numbers may increment multiple times during Xorg server development cycles, to track changes for those following the head of the development stream. X.Org tries to avoid changing ABI's incompatibly in stable release branches, but may add compatible changes which increment the minor number.
+
[[!table header="no" class="mointable" data="""
- **Xorg Version:** | **[[1.3|Server13Branch]]** | **[[1.4|Server14Branch]]** | **[[1.5|Server15Branch]]** | **[[1.6|Server16Branch]]** | **[[1.7|Server17Branch]]** | **1.8** | **1.9** | **1.10** | **1.11**
- ABI_ANSIC_VERSION | 0.3 | 0.3 | 0.4 | 0.4 | 0.4 | 0.4 | 0.4 | 0.4 | 0.4
- ABI_VIDEODRV_VERSION | 1.2 | 2.0 | 4.1 | 5.0 | 6.0 | 7.0 | 8.0 | 10.0 | 11.0
- ABI_XINPUT_VERSION | 0.7 | 2.0 | 2.1 | 4.0 | 7.0 | 9.0 | 11.0 | 12.2 | 13.0
- ABI_EXTENSION_VERSION | 0.3 | 0.3 | 1.1 | 2.0 | 2.0 | 3.0 | 4.0 | 5.0 | 5.0
- ABI_FONT_VERSION | 0.5 | 0.5 | 0.6 | 0.6 | 0.6 | 0.6 | 0.6 | 0.6 | 0.6
+ **Xorg Version:** | **[[1.3|Server13Branch]]** | **[[1.4|Server14Branch]]** | **[[1.5|Server15Branch]]** | **[[1.6|Server16Branch]]** | **[[1.7|Server17Branch]]** | **[[1.8|Server18Branch]]** | **[[1.9|Server19Branch]]** | **[[1.10|Server110Branch]]** | **[[1.11|Server111Branch]]** | **[[1.12|Server112Branch]]** | **[[1.13|Server113Branch]]** | **[[1.14|Server114Branch]]**
+ ABI_ANSIC_VERSION | 0.3 | 0.3 | 0.4 | 0.4 | 0.4 | 0.4 | 0.4 | 0.4 | 0.4 | 0.4 | 0.4 | 0.4
+ ABI_VIDEODRV_VERSION | 1.2 | 2.0 | 4.1 | 5.0 | 6.0 | 7.0 | 8.0 | 10.0 | 11.0 | 12.0 | 13.0 | 14.1
+ ABI_XINPUT_VERSION | 0.7 | 2.0 | 2.1 | 4.0 | 7.0 | 9.0 | 11.0 | 12.2 | 13.0 | 16.0 | 18.0 | 19.1
+ ABI_EXTENSION_VERSION | 0.3 | 0.3 | 1.1 | 2.0 | 2.0 | 3.0 | 4.0 | 5.0 | 5.0 | 6.0 | 7.0 | 7.0
+ ABI_FONT_VERSION | 0.5 | 0.5 | 0.6 | 0.6 | 0.6 | 0.6 | 0.6 | 0.6 | 0.6 | 0.6 | 0.6 | 0.6
"""]]
+When looking at Xserver source code, the ABI versions may be found in `hw/xfree86/common/xf86Module.h`.
## Input ABI policy