summaryrefslogtreecommitdiff
path: root/XorgModuleABIVersions.mdwn
diff options
context:
space:
mode:
authorAlanCoopersmith <AlanCoopersmith@web>2013-09-18 21:22:15 -0700
committerxorg <iki-xorg@freedesktop.org>2013-09-18 21:22:15 -0700
commit368a1a72ed22d371486bb4984f3cfc31452a325e (patch)
treec6995c73c9e7119eb8d4b0c88d1f19e4df7b2a85 /XorgModuleABIVersions.mdwn
parent85843f5dc9b2634cb2cb20e33087b8c714cbe562 (diff)
flip table axes before it gets too wide for browser pages
Diffstat (limited to 'XorgModuleABIVersions.mdwn')
-rw-r--r--XorgModuleABIVersions.mdwn22
1 files changed, 15 insertions, 7 deletions
diff --git a/XorgModuleABIVersions.mdwn b/XorgModuleABIVersions.mdwn
index 76ddbe58..4abbf419 100644
--- a/XorgModuleABIVersions.mdwn
+++ b/XorgModuleABIVersions.mdwn
@@ -7,15 +7,23 @@ Modules reporting they require a incompatible version number will not be loaded
ABI numbers may increment multiple times during Xorg server development cycles, to track changes for those following the head of the development stream. X.Org tries to avoid changing ABI's incompatibly in stable release branches, but may add compatible changes which increment the minor number.
[[!table header="no" class="mointable" data="""
- **Xorg Version:** | **[[1.3|Server13Branch]]** | **[[1.4|Server14Branch]]** | **[[1.5|Server15Branch]]** | **[[1.6|Server16Branch]]** | **[[1.7|Server17Branch]]** | **[[1.8|Server18Branch]]** | **[[1.9|Server19Branch]]** | **[[1.10|Server110Branch]]** | **[[1.11|Server111Branch]]** | **[[1.12|Server112Branch]]** | **[[1.13|Server113Branch]]** | **[[1.14|Server114Branch]]**
- ABI_ANSIC_VERSION | 0.3 | 0.3 | 0.4 | 0.4 | 0.4 | 0.4 | 0.4 | 0.4 | 0.4 | 0.4 | 0.4 | 0.4
- ABI_VIDEODRV_VERSION | 1.2 | 2.0 | 4.1 | 5.0 | 6.0 | 7.0 | 8.0 | 10.0 | 11.0 | 12.0 | 13.0 | 14.1
- ABI_XINPUT_VERSION | 0.7 | 2.0 | 2.1 | 4.0 | 7.0 | 9.0 | 11.0 | 12.2 | 13.0 | 16.0 | 18.0 | 19.1
- ABI_EXTENSION_VERSION | 0.3 | 0.3 | 1.1 | 2.0 | 2.0 | 3.0 | 4.0 | 5.0 | 5.0 | 6.0 | 7.0 | 7.0
- ABI_FONT_VERSION | 0.5 | 0.5 | 0.6 | 0.6 | 0.6 | 0.6 | 0.6 | 0.6 | 0.6 | 0.6 | 0.6 | 0.6
+| **ABI Versions:** (`ABI_*_VERSION`) ||||
+**Xorg Version:** | **ANSIC** | **VIDEODRV** | **XINPUT** | **EXTENSION** | **FONT**
+**[[1.3|Server13Branch]]** | 0.3 | 1.2 | 0.7 | 0.3 | 0.5
+**[[1.4|Server14Branch]]** | 0.3 | 2.0 | 2.0 | 0.3 | 0.5
+**[[1.5|Server15Branch]]** | 0.4 | 4.1 | 2.1 | 1.1 | 0.6
+**[[1.6|Server16Branch]]** | 0.4 | 5.0 | 4.0 | 2.0 | 0.6
+**[[1.7|Server17Branch]]** | 0.4 | 6.0 | 7.0 | 2.0 | 0.6
+**[[1.8|Server18Branch]]** | 0.4 | 7.0 | 9.0 | 3.0 | 0.6
+**[[1.9|Server19Branch]]** | 0.4 | 8.0 | 11.0 | 4.0 | 0.6
+**[[1.10|Server110Branch]]** | 0.4 | 10.0 | 12.2 | 5.0 | 0.6
+**[[1.11|Server111Branch]]** | 0.4 | 11.0 | 13.0 | 5.0 | 0.6
+**[[1.12|Server112Branch]]** | 0.4 | 12.0 | 16.0 | 6.0 | 0.6
+**[[1.13|Server113Branch]]** | 0.4 | 13.0 | 18.0 | 7.0 | 0.6
+**[[1.14|Server114Branch]]** | 0.4 | 14.1 | 19.1 | 7.0 | 0.6
"""]]
-When looking at Xserver source code, the ABI versions may be found in `hw/xfree86/common/xf86Module.h`.
+When looking at Xserver source code, the ABI versions may be found as definitions of `ABI_VIDEODRV_VERSION`, `ABI_XINPUT_VERSION`, etc. in `hw/xfree86/common/xf86Module.h`.
## Input ABI policy