summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ecaea63f..7329c068 100644
--- a/configure.ac
+++ b/configure.ac
@@ -128,6 +128,24 @@ if test x$enable_android_compositor = xyes; then
PKG_CHECK_MODULES(ANDROID_COMPOSITOR, [mtdev >= 1.1.0])
fi
+
+AC_ARG_ENABLE(rpi-compositor,
+ AS_HELP_STRING([--disable-rpi-compositor],
+ [do not build the Raspberry Pi backend]),,
+ enable_rpi_compositor=yes)
+AM_CONDITIONAL(ENABLE_RPI_COMPOSITOR, test "x$enable_rpi_compositor" = "xyes")
+have_bcm_host="no"
+if test x$enable_rpi_compositor = xyes; then
+ AC_DEFINE([BUILD_RPI_COMPOSITOR], [1], [Build the compositor for Raspberry Pi])
+ PKG_CHECK_MODULES(RPI_COMPOSITOR, [libudev >= 136 mtdev >= 1.1.0])
+ PKG_CHECK_MODULES(RPI_BCM_HOST, [bcm_host],
+ [have_bcm_host="yes"
+ AC_DEFINE([HAVE_BCM_HOST], [1], [have Raspberry Pi BCM headers])],
+ [AC_MSG_WARN([Raspberry Pi BCM host libraries not found, will use stubs instead.])])
+fi
+AM_CONDITIONAL(INSTALL_RPI_COMPOSITOR, test "x$have_bcm_host" = "xyes")
+
+
AC_ARG_WITH(cairo-glesv2,
AS_HELP_STRING([--with-cairo-glesv2],
[Use GLESv2 cairo instead of full GL]))