summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Champagne <champagne.guillaume.c@gmail.com>2020-06-01 21:59:12 -0400
committerPekka Paalanen <pq@iki.fi>2020-06-03 11:00:21 +0000
commit7451f9956ea80437e5b561c6bc0ccbfe48db5a2c (patch)
treee5ad82c9ecd2f4c3bb2665955425dc6936192e59
parentb1c529e9d719b4a1afa713eb739b9f2b31dc0743 (diff)
meson: add lcms2 dependency to cms-colord
cms-colord uses cms-helper functions which require lcms2. Therefore, lcms2 must be added as a build dependency. Signed-off-by: Guillaume Champagne <champagne.guillaume.c@gmail.com>
-rw-r--r--compositor/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/compositor/meson.build b/compositor/meson.build
index 621c3e07..6352a110 100644
--- a/compositor/meson.build
+++ b/compositor/meson.build
@@ -137,7 +137,7 @@ if get_option('color-management-colord')
error('cms-colord requires colord >= 0.1.27 which was not found. Or, you can use \'-Dcolor-management-colord=false\'.')
endif
- plugin_colord_deps = [ dep_libweston_public, dep_colord ]
+ plugin_colord_deps = [ dep_libweston_public, dep_colord, dep_lcms2 ]
foreach depname : [ 'glib-2.0', 'gobject-2.0' ]
dep = dependency(depname, required: false)