summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6d027708..0d34623a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,10 +59,18 @@ else
fi
AM_CONDITIONAL([HAVE_DOXYGEN], [test "x$have_doxygen" = "xyes"])
+AC_ARG_ENABLE(tests,
+ AS_HELP_STRING([--enable-tests], [Build the tests (default=yes)]),
+ [build_tests="$enableval"],
+ [build_tests="yes"])
+
+AM_CONDITIONAL(BUILD_TESTS, [test "x$build_tests" = "xyes"])
+
AC_CONFIG_FILES([Makefile
doc/Makefile
doc/libinput.doxygen
src/Makefile
src/libinput.pc
- src/libinput-version.h])
+ src/libinput-version.h
+ test/Makefile])
AC_OUTPUT