summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHans de Goede <hdegoede@redhat.com>2014-06-06 17:01:05 +0200
committerPeter Hutterer <peter.hutterer@who-t.net>2014-06-10 20:55:18 +1000
commitf638677051f4ac1e6b587a0c414baca9c098130e (patch)
treed4f91994ab81e4d4d4e21d68193dcea4b58efada /src/Makefile.am
parent7222f839d0008ad5bebc9ff25853bdcf14480c63 (diff)
Add a timer subsystem
Currently we are using DIY timers in the touchpad softbutton and tap handling code, and at least the softbutton code gets its wrong. It uses one timer-fd per touchpad to set a timeout per touch, which means that if a timeout is set for 100ms from now for touch 1, and then 50 ms later touch 2 sets a timeout for 200 ms from now, then the timeout for touch 1 will come 150 ms too late. This commits adds a proper timer subsystem so that we've one place to deal with timer handling, and so that we can only get it wrong (well hopefully we get it right) in one place. Signed-off-by: Hans de Goede <hdegoede@redhat.com> Reviewed-by: Peter Hutterer <peter.hutterer@who-t.net> Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ff93911c..bf561845 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -21,6 +21,8 @@ libinput_la_SOURCES = \
path.c \
udev-seat.c \
udev-seat.h \
+ timer.c \
+ timer.h \
../include/linux/input.h
libinput_la_LIBADD = $(MTDEV_LIBS) \