summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2017-09-06 11:01:49 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2017-11-17 09:22:37 +1000
commitfca003d305ea83f8f09f0bd0dbfc54ece4d2cc04 (patch)
treed28d187e1adbce786f3cc66791d7631cd768b3d2 /meson.build
parent2fc394dcde6d9e2140c03f216db9530fb5f2933f (diff)
tools: replace the tap time measuring tool with a python one
A lot easier to process data in python than in C. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Reviewed-By: Dima Ryazanov <dima@gmail.com> Tested-By: Dima Ryazanov <dima@gmail.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 2 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index eefe3d61..4d433989 100644
--- a/meson.build
+++ b/meson.build
@@ -414,14 +414,8 @@ configure_file(input : 'tools/libinput-measure.man',
install_dir : join_paths(get_option('mandir'), 'man1')
)
-libinput_measure_touchpad_tap_sources = [ 'tools/libinput-measure-touchpad-tap.c' ]
-executable('libinput-measure-touchpad-tap',
- libinput_measure_touchpad_tap_sources,
- dependencies : deps_tools,
- include_directories : [includes_src, includes_include],
- install_dir : libinput_tool_path,
- install : true,
- )
+install_data('tools/libinput-measure-touchpad-tap',
+ install_dir : libinput_tool_path)
configure_file(input : 'tools/libinput-measure-touchpad-tap.man',
output : 'libinput-measure-touchpad-tap.1',
configuration : man_config,