summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2018-03-07 08:48:01 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2018-03-07 08:48:01 +1000
commitf734e973be202141ac7352439fd2c1812c89d108 (patch)
tree9ecdf3c999c197b12ede749ee9a46975d0323e84 /meson.build
parentcd63ba2cc0d32608a0f2f4c7ced6016cde0fc60c (diff)
meson: make libinput-git-version.h a source of libinput-record
Fixes the dependency chain, otherwise a race condition between building libinput-record and building the git version header causes random build failures. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 5 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index ba24a6fc..8591162c 100644
--- a/meson.build
+++ b/meson.build
@@ -240,10 +240,10 @@ pkgconfig.generate(
libraries : lib_libinput
)
-vcs_tag(['git', 'describe'],
- 'unknown',
- input : 'src/libinput-git-version.h.in',
- output :'libinput-git-version.h')
+git_version_h = vcs_tag(['git', 'describe'],
+ 'unknown',
+ input : 'src/libinput-git-version.h.in',
+ output :'libinput-git-version.h')
# Restore the SELinux context for the libinput.so.a.b.c on install
# meson bug https://github.com/mesonbuild/meson/issues/1967
@@ -469,7 +469,7 @@ configure_file(input : 'tools/libinput-measure-trackpoint-range.man',
install_dir : join_paths(get_option('mandir'), 'man1')
)
-libinput_record_sources = [ 'tools/libinput-record.c' ]
+libinput_record_sources = [ 'tools/libinput-record.c', git_version_h ]
executable('libinput-record',
libinput_record_sources,
dependencies : deps_tools,