summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2018-04-13 14:39:58 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2018-04-13 14:58:46 +1000
commite428e5e87a83127db90476e5a7d7e48546fafd6f (patch)
tree53dac9a80b15ae310ae04ce860dd74f4c8fd6ab8 /meson.build
parent69fe467fbacbc8376d548c335c79cca71b606b07 (diff)
meson: only run the selinux restore script on meson < 0.43
Meson handles this now, see meson commits 1826872 and follow-up c63aa037. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 7 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index aeb734d8..fa572b6d 100644
--- a/meson.build
+++ b/meson.build
@@ -245,11 +245,13 @@ git_version_h = vcs_tag(command : ['git', 'describe'],
input : 'src/libinput-git-version.h.in',
output :'libinput-git-version.h')
-# Restore the SELinux context for the libinput.so.a.b.c on install
-# meson bug https://github.com/mesonbuild/meson/issues/1967
-meson.add_install_script('src/libinput-restore-selinux-context.sh',
- join_paths(get_option('prefix'), get_option('libdir')),
- lib_libinput.full_path())
+if meson.version().version_compare('<0.4.3.0')
+ # Restore the SELinux context for the libinput.so.a.b.c on install
+ # meson bug https://github.com/mesonbuild/meson/issues/1967
+ meson.add_install_script('src/libinput-restore-selinux-context.sh',
+ join_paths(get_option('prefix'), get_option('libdir')),
+ lib_libinput.full_path())
+endif
############ documentation ############