summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorQuentin Glidic <sardemff7+git@sardemff7.net>2017-11-30 09:23:38 +0100
committerPeter Hutterer <peter.hutterer@who-t.net>2018-02-16 16:57:30 +1000
commitb2b5cdaf61a79fb42aecf86af24b21a5372eed4b (patch)
tree81ffcc1a46d7b7f27f10943aecc2521c95e3d678 /meson.build
parent0843fa8e5e477a926eb7536c47c5421f8ddf8759 (diff)
meson: Fix absolute libdir case in install script
If libdir is an absolute path (which means it’s outside of prefix) we would wrongly add the prefix to it in the install script. Just pass the correct libdir from Meson directly thanks to join_paths() magic. Signed-off-by: Quentin Glidic <sardemff7+git@sardemff7.net> Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 5a0228ee..ec13d93a 100644
--- a/meson.build
+++ b/meson.build
@@ -234,7 +234,7 @@ pkgconfig.generate(
# Restore the SELinux context for the libinput.so.a.b.c on install
# meson bug https://github.com/mesonbuild/meson/issues/1967
meson.add_install_script('src/libinput-restore-selinux-context.sh',
- get_option('libdir'),
+ join_paths(get_option('prefix'), get_option('libdir')),
lib_libinput.full_path())
############ documentation ############