summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2018-06-21 17:05:30 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2018-06-26 11:18:31 +1000
commit5ca1862bde4f052e8e27628dea2423f3db9499c1 (patch)
tree877b6c23874a8318cfc0f40de44d1eac2e399b8e /meson.build
parent07a0d04fd35a504d6788856e476d1d0fefedc288 (diff)
test: add a libinput-test runner for 'deviceless' tests
These are tests that don't need *any* uinput devices at all. Mark them accordingly and create a new binary that only runs those tests. This way we can run some of the test suite even in containers where we're restricted. Better have 10% tested than none, I guess. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index b650bbde..b43b7e49 100644
--- a/meson.build
+++ b/meson.build
@@ -861,6 +861,14 @@ if get_option('tests')
libinput_test_runner,
timeout : 1200)
+ libinput_test_deviceless = executable('libinput-test-deviceless',
+ libinput_test_runner_sources,
+ include_directories : [includes_src, includes_include],
+ dependencies : deps_litest,
+ c_args : [ def_LT_VERSION, '-DDISABLE_DEVICE_TESTS=1' ],
+ install : false)
+ test('libinput-test-deviceless', libinput_test_deviceless)
+
valgrind_env = environment()
valgrind_env.set('CK_FORK', 'no')
valgrind_env.set('USING_VALGRIND', '1')