summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2018-06-20 08:15:14 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2018-06-20 11:26:57 +1000
commit4203ab52bfd249a50bbfa305bb48f4b42e73a714 (patch)
treefc7b90e46c1f5dc6e4b402defbb5a83027535c3a /meson.build
parent1605f71a0bd31f1e719a537bbccb8135d9700aa4 (diff)
meson.build: add a libinput list-devices run to the test suite
This will only catch a segfault or some other bug since we don't actually look at the output. But that's still better than not running it at all. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 9 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index fed59e47..54c5bbe0 100644
--- a/meson.build
+++ b/meson.build
@@ -488,13 +488,15 @@ configure_file(input : 'tools/libinput-list-quirks.man',
)
libinput_list_devices_sources = [ 'tools/libinput-list-devices.c' ]
-executable('libinput-list-devices',
- libinput_list_devices_sources,
- dependencies : deps_tools,
- include_directories : [includes_src, includes_include],
- install_dir : libinput_tool_path,
- install : true,
- )
+libinput_list_devices = executable('libinput-list-devices',
+ libinput_list_devices_sources,
+ dependencies : deps_tools,
+ include_directories : [includes_src, includes_include],
+ install_dir : libinput_tool_path,
+ install : true,
+ )
+test('list-devices', libinput_list_devices)
+
configure_file(input : 'tools/libinput-list-devices.man',
output : 'libinput-list-devices.1',
configuration : man_config,